Our top priority

We are as proud of our service as we are of our robots.

Forgot your password?
Register

Splash Forums Development SDK SDK on USB stick broken

This topic contains 6 replies, has 2 voices, and was last updated by  martine 9 months, 2 weeks ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #4382

    rongoldman
    Participant

    Hi. We just received some new 7 DoF JACO arms and are having some problems using the SDK on the USB stick that accompanied the arms.

    1. The various executables (e.g. GUI/DevelopmentCenter.sh, GUI/bin/*) do not have the executable permission set.

    2. There is a typo in GUI/DevelopmentCenter.sh where it tries to set the LD_LIBRARY_PATH to include $dirname/plateforms

    3. Running on an Intel NUC computer with Ubuntu 14.04 the DevelopmentCenter windows were scrunched up. I.e. the various forms were displayed in too small a space, and making the window larger did not resize the GUI area. Running on a larger Puget Desktop things work fine. (Note: same version of Ubuntu, same display monitor.)

    4. Trying to set new home & retracted positions took many tries (and reboots of the arm) before the change took. Some of the problem lies in the DevelopmentCenter GUI where there is no apparent way to command the arm to move to any of the stored positions in order to check that they are correct & pushing the Save button gives no feedback if anything was saved.

    Otherwise the new 7 DoF arms seem really nice!

    thanks,

    — Ron —

    #4383

    rongoldman
    Participant

    Whoops it looks like the new retracted position is not being saved. It may be that the home position is also not being saved, but it changed when I modified the arm from left-handed to right-handed.

    #4386

    rongoldman
    Participant

    Here are some more details:

    1. On starting DevelopmentCenter:

    % ./DevelopmentCenter.sh
    LD_LIBRARY_PATH=/opt/ros/indigo/lib:/opt/JACO2SDK/GUI/./lib/.:/opt/JACO2SDK/GUI/./bin/.:/opt/JACO2SDK/GUI/./platforms/.
    linux-vdso.so.1 => (0x00007ffeab68f000)
    libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f788be73000)
    libQt5WebKitWidgets.so.5 => /usr/lib/x86_64-linux-gnu/libQt5WebKitWidgets.so.5 (0x00007f788bc30000)
    libQt5Widgets.so.5 => /opt/JACO2SDK/GUI/./lib/./libQt5Widgets.so.5 (0x00007f788b3e0000)
    libQt5Gui.so.5 => /opt/JACO2SDK/GUI/./lib/./libQt5Gui.so.5 (0x00007f788ac54000)
    libQt5Xml.so.5 => /opt/JACO2SDK/GUI/./lib/./libQt5Xml.so.5 (0x00007f788aa18000)
    libQt5Network.so.5 => /opt/JACO2SDK/GUI/./lib/./libQt5Network.so.5 (0x00007f788a6ba000)
    libQt5Core.so.5 => /opt/JACO2SDK/GUI/./lib/./libQt5Core.so.5 (0x00007f7889f9c000)
    libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f7889c97000)
    libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f7889a81000)
    libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f78896b8000)
    /lib64/ld-linux-x86-64.so.2 (0x000056082f353000)
    libQt5WebKit.so.5 => /usr/lib/x86_64-linux-gnu/libQt5WebKit.so.5 (0x00007f78873eb000)
    libQt5OpenGL.so.5 => /opt/JACO2SDK/GUI/./lib/./libQt5OpenGL.so.5 (0x00007f7887194000)
    libQt5PrintSupport.so.5 => /opt/JACO2SDK/GUI/./lib/./libQt5PrintSupport.so.5 (0x00007f7886f28000)
    libQt5Sensors.so.5 => /opt/JACO2SDK/GUI/./lib/./libQt5Sensors.so.5 (0x00007f7886cea000)
    libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f7886acc000)
    libGL.so.1 => /usr/lib/nvidia-375/libGL.so.1 (0x00007f7886828000)
    libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f7886521000)
    libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f7886308000)
    libicui18n.so.56 => /opt/JACO2SDK/GUI/./lib/./libicui18n.so.56 (0x00007f7885e6d000)
    libicuuc.so.56 => /opt/JACO2SDK/GUI/./lib/./libicuuc.so.56 (0x00007f7885ab5000)
    libicudata.so.56 => /opt/JACO2SDK/GUI/./lib/./libicudata.so.56 (0x00007f78840d2000)
    libgthread-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgthread-2.0.so.0 (0x00007f7883ecf000)
    librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f7883cc7000)
    libglib-2.0.so.0 => /lib/x86_64-linux-gnu/libglib-2.0.so.0 (0x00007f78839bf000)
    libXrender.so.1 => /usr/lib/x86_64-linux-gnu/libXrender.so.1 (0x00007f78837b4000)
    libXcomposite.so.1 => /usr/lib/x86_64-linux-gnu/libXcomposite.so.1 (0x00007f78835b1000)
    libjpeg.so.8 => /usr/lib/x86_64-linux-gnu/libjpeg.so.8 (0x00007f788335c000)
    libpng12.so.0 => /lib/x86_64-linux-gnu/libpng12.so.0 (0x00007f7883135000)
    libicui18n.so.52 => /usr/lib/x86_64-linux-gnu/libicui18n.so.52 (0x00007f7882d2e000)
    libicuuc.so.52 => /usr/lib/x86_64-linux-gnu/libicuuc.so.52 (0x00007f78829b5000)
    libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007f788267f000)
    libxslt.so.1 => /usr/lib/x86_64-linux-gnu/libxslt.so.1 (0x00007f7882442000)
    libxml2.so.2 => /usr/lib/x86_64-linux-gnu/libxml2.so.2 (0x00007f78820db000)
    libgobject-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0 (0x00007f7881e89000)
    libgstreamer-1.0.so.0 => /usr/lib/x86_64-linux-gnu/libgstreamer-1.0.so.0 (0x00007f7881b85000)
    libgstapp-1.0.so.0 => /usr/lib/x86_64-linux-gnu/libgstapp-1.0.so.0 (0x00007f7881978000)
    libgstbase-1.0.so.0 => /usr/lib/x86_64-linux-gnu/libgstbase-1.0.so.0 (0x00007f788171f000)
    libgstpbutils-1.0.so.0 => /usr/lib/x86_64-linux-gnu/libgstpbutils-1.0.so.0 (0x00007f78814f9000)
    libgstvideo-1.0.so.0 => /usr/lib/x86_64-linux-gnu/libgstvideo-1.0.so.0 (0x00007f78812b3000)
    libgstaudio-1.0.so.0 => /usr/lib/x86_64-linux-gnu/libgstaudio-1.0.so.0 (0x00007f7881068000)
    libsqlite3.so.0 => /usr/lib/x86_64-linux-gnu/libsqlite3.so.0 (0x00007f7880daf000)
    libQt5Quick.so.5 => /opt/JACO2SDK/GUI/./lib/./libQt5Quick.so.5 (0x00007f78807be000)
    libQt5Qml.so.5 => /opt/JACO2SDK/GUI/./lib/./libQt5Qml.so.5 (0x00007f78801c5000)
    libQt5Sql.so.5 => /opt/JACO2SDK/GUI/./lib/./libQt5Sql.so.5 (0x00007f787ff80000)
    libQt5Positioning.so.5 => /opt/JACO2SDK/GUI/./lib/./libQt5Positioning.so.5 (0x00007f787fd41000)
    libGLX.so.0 => /usr/lib/nvidia-375/libGLX.so.0 (0x00007f787fb10000)
    libGLdispatch.so.0 => /usr/lib/nvidia-375/libGLdispatch.so.0 (0x00007f787f842000)
    libpcre.so.3 => /lib/x86_64-linux-gnu/libpcre.so.3 (0x00007f787f603000)
    libicudata.so.52 => /usr/lib/x86_64-linux-gnu/libicudata.so.52 (0x00007f787dd96000)
    libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007f787db76000)
    liblzma.so.5 => /lib/x86_64-linux-gnu/liblzma.so.5 (0x00007f787d954000)
    libffi.so.6 => /usr/lib/x86_64-linux-gnu/libffi.so.6 (0x00007f787d74c000)
    libgmodule-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgmodule-2.0.so.0 (0x00007f787d547000)
    liborc-0.4.so.0 => /usr/lib/x86_64-linux-gnu/liborc-0.4.so.0 (0x00007f787d2c5000)
    libgsttag-1.0.so.0 => /usr/lib/x86_64-linux-gnu/libgsttag-1.0.so.0 (0x00007f787d08c000)
    libXext.so.6 => /usr/lib/x86_64-linux-gnu/libXext.so.6 (0x00007f787ce7a000)
    libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007f787cc75000)
    libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007f787ca6f000)
    Initializing sockets . . .
    Creating sockets . . .
    Sockets creation successful.

    Binding socket to address . . .
    Bind failed with error
    Initializing sockets . . .
    Creating sockets . . .
    Sockets creation successful.

    Binding socket to address . . .
    Bind failed with error
    Initializing sockets . . .
    Creating sockets . . .
    Sockets creation successful.

    Binding socket to address . . .
    Bind failed with error

    ————-

    Why the error messages here? Is this from looking for an arm connected using ethernet? Our arm is connected via USB.

    2. After clicking on the “General menu” button to bring up the Configuration window:

    libpng warning: iCCP: known incorrect sRGB profile

    3. After clicking on the “Virtual Joystoick” button:

    QLayout: Attempting to add QLayout “” to CAbstractModuleFrame “m_MainPanel”, which already has a layout

    4. My problem setting new retracted & home locations was not noticing the (tiny) Activate checkbox above the position list. Once I clicked it things worked much better. Though it would still be nice to add a button that would move to the selected position.

    5. The stored retracted & home positions do not seem to be saving (or reading?) the value for joint 7. After rebooting the arm that joint moves to a position of 0 degrees.

    There also were some problems installing the SDK:

    6. For Ubuntu 14_04 / 64 bits the executable permission is not set for installSDK54.sh & SDK_JACO2_1.4.0_install64. So one needs to manually copy that folder to the computer’s disk & change the permissions to install the SDK.

    7. Doing the install using sudo results in inaccessible folders in the /opt/JACO2SDK folder. The permissions are too restrictive:

    % ls -l /opt/JACO2SDK-test/
    total 27028
    drwx—— 2 root root 4096 Jul 10 10:57 API
    -rw-r–r– 1 root root 3347 Jul 10 10:57 components.xml
    drwx—— 3 root root 4096 Jul 10 10:57 Documentation
    drwx—— 12 root root 4096 Jul 10 10:57 Examples
    drwx—— 9 root root 4096 Jul 10 10:57 GUI
    drwx—— 2 root root 4096 Jul 10 10:57 Guides
    -rw-rw-r– 1 root root 22002 Apr 27 2015 Icon_torque.png
    -rw-r–r– 1 root root 3500 Jul 10 10:57 InstallationLog.txt
    drwxr-xr-x 2 root root 4096 Jul 10 10:57 Licenses
    -rwxr-xr-x 1 root root 26977856 Jul 10 10:57 maintenancetool
    -rw-r–r– 1 root root 622147 Jul 10 10:57 maintenancetool.dat
    -rw-r–r– 1 root root 2653 Jul 10 10:57 maintenancetool.ini
    -rw-r–r– 1 root root 362 Jul 10 10:57 network.xml
    drwx—— 3 root root 4096 Jul 10 10:57 RobotConfiguration
    -rw-rw-r– 1 root root 2855 Dec 12 2014 SDK.png

    8. Executables in the subdirectories do not have the executable permission set. E.g. GUI/DevelopmentCenter*, GUI/bin/*, Examples/Example_AngularControl/Debug/Example_AngularControl

    Hopefully a new SDK that has been tested on Ubuntu will be made available.

    thanks,

    — Ron —

    #4387

    rongoldman
    Participant

    One last update:

    Please ignore point 3 in the first post, the problem was a system setting in Displays. The scale for menu and title bars was set to 1.85. When I reset it to 1 the DevelopmentCenter windows were displayed correctly.

    #4400

    martine
    Participant

    Hi Ron

    Thank you for your suggestions and comments.

    Point 5 seem to be a bug with our Dev Center application. This functionality is generally used by our Assistive division customers, who do not generally have a 7 dof robot. Have you tried to send an Advanced Home/Retract sequence directly using the API (setClientConfiguration) by any chance? It should be working. Is this functionality important for you? Generally speaking, you can also send angular trajectory positions to get – to some extent – similar results.

    For point 1: yes this comes from the fact that you have no robot connected via Ethernet
    For point 2: this is a warning that does not seem to affect the SDK functionality, but thank you for pointing that out.
    For point 4: thanks for the suggestion
    For point 6-8: We understand this is not ideal to have to modify the default permission. There also seem to be a discrepancy between Ubuntu 14.04 and Ubuntu 16.04 on that permission matter. My recommendation is to do a sudo chmod 777 -R on the whole 64bit folder and a sudo chown your_user_name -R also on the whole 64bit folder. Then you should not experience other permission issue.

    All the best,

    Martine

    #4402

    rongoldman
    Participant

    Martine,

    Thanks. I haven’t tried calling setClientConfiguration since it is not available through the ROS interface. For now we can live with joint 7 always being 0 degrees for the retracted & home positions. The saved positions won’t matter once we start running an application.

    I’ll try out your recommended fix for the permissions issues (I did something similar) and pass it on to my teammates who will be installing the SDK on their computers.

    Any idea when an updated version of the SDK might be downloadable from the Kinova web site?

    — Ron —

    #4414

    martine
    Participant

    Hi Ron

    Updated version should come sometime end of August. Thanks for your feedback

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

Trending now

Expert Talk

Hitting the Mark with Marketing: The Do’s and Don’ts of Creating a Message Around Robotics

While robotics companies have been around for decades, the spotlight on the industry has only really intensified in recent years as new technologies become more readily available and more implicated in the lives of humans.

Read more
Expert Talk

For the Greater Good: The Importance of Fulfilling Corporate Social Responsibility

By now, it goes without saying that the cornerstone of Kinova’s DNA is our desire to create products that empower humanity, and that fulfilling our ethical, human and social responsibilities is fundamental to maintaining the core of our culture. Always has been, always will be.

Read more
Expert Talk

FOR ETHICS IN AI, KEEP HUMANS in THE LOOP (UNTIL FURTHER NOTICE.)

As discussions around the advancement of AI evolve, so too do the concerns. And for good reason. Machines are getting smarter and smarter, able to complete complex tasks and process information incredibly fast. But, what happens when the developments in AI move too quickly — and we lose sight of human ethics?

Read more